Welcome to MapForums!

Register, sign in, or use Facebook Connect above to join in and participate in the forum.

When you are signed in, this message, the ads in this row, and the red-underlined link ads all go away.

Subscribe to receive our newsletter.
Subscribe Unsubscribe
Results 1 to 7 of 7

400: Bad Request for Virtual Earth Web Service

This is a discussion on 400: Bad Request for Virtual Earth Web Service within the Bing Maps Blogs & Tweets forums, part of the Blogs category; I've been getting quite a few messages about this "400: Bad Request" error people are seeing when trying to reference ...

  1. #1
    VirtualEarth MSDN Blog is offline Senior Member Blue Belt
    Join Date
    Sep 2007
    Posts
    379

    400: Bad Request for Virtual Earth Web Service

    I've been getting quite a few messages about this "400: Bad Request" error people are seeing when trying to reference the Virtual Earth Web Service, more specifically when trying to fetch tokens so it's worth posting a little something on how to fix it. Specifically, the error is, "There was an error downloading 'http://staging.common.virtualearth.net/find-30/common.asmx'. The request failed with HTTP status 400: Bad Request."

    The current documentation in the SDK shows a reference to https://staging.common.virtualearth.net/find-30/common.asmx; however, users aren't getting the WSDL downloaded (I've had this problem myself). So, the solution is to change the reference to https://staging.common.virtualearth.net/find-30/common.asmx?wsdl.

    In Visual Studio 2008, you'll need to take a (odd) extra step. For some reason adding a Web Reference is different when you go to the "Add Service" advanced options than if you were to just Add Web Reference from Website menu. So, in Visual Studio 2008...

    1. Select the “Add Service Reference…” item from the Website menu.
    2. Click on the “Advanced…” button.
    3. Click on the “Add Web Reference…” button.
    4. Enter http://staging.common.virtualearth.net/find-30/common.asmx?wsdl for the URL and then hit the “Go” button.
    5. When prompted, enter your Virtual Earth Developer Account ID and password.
    6. Once WSDL has been downloaded, give the web reference a meaningful name like “TokenService” then click the “Add Reference” button.

    This should fix your issues. We'll be updating the SDK soon too.

    CP



    Click here to view the article.

  2. #2
    vinayakmanohar is offline Junior Member White Belt
    Join Date
    Jan 2009
    Posts
    2

    Re: 400: Bad Request for Virtual Earth Web Service

    I still get this error -
    There was an error downloading 'https://staging.common.virtualearth.net/find-30/common.asmx?WSDL'.
    The request failed with HTTP status 400: Bad Request.
    There was an error downloading 'https://staging.common.virtualearth.net/find-30/common.asmx?WSDL/$metadata'.
    The request failed with HTTP status

  3. #3
    raveev is offline Junior Member White Belt
    Join Date
    Apr 2009
    Posts
    1

    Re: 400: Bad Request for Virtual Earth Web Service

    What version of IE are you using?

    Upgrade to IE 7

    Thanks
    Ravi Vridhagiri

  4. #4
    Eric Frost's Avatar
    Eric Frost is offline Administrator Black Belt
    Join Date
    Jul 1992
    Posts
    5,094
    Blog Entries
    4

    Re: 400: Bad Request for Virtual Earth Web Service

    upgrade to Safari, hehe.
    ~ Order MapPoint MapPoint 2013 Here and Get Free Access to the MapForums Downloads ~
    ~~
    ~ Upgrade to Get Access to the MapForums Downloads ~

  5. #5
    vinayakmanohar is offline Junior Member White Belt
    Join Date
    Jan 2009
    Posts
    2

    Re: 400: Bad Request for Virtual Earth Web Service

    I am using IE7.

  6. #6
    auto_tim is offline Junior Member White Belt
    Join Date
    Aug 2009
    Posts
    1

    Re: 400: Bad Request for Virtual Earth Web Service

    Hi,

    I'm having the same problem as described here.
    I'm using Win7 RC1, VC# 2008 Express, IE8. At the "Add Web Reference" page, when using either of the two (http or https) URLs shown above I get the error:
    There was an error downloading 'http://staging.common.virtualearth.net/find-30/common.asmx?wsdl'.
    The request failed with HTTP status 400: Bad Request.
    There was an error downloading 'http://staging.common.virtualearth.net/find-30/common.asmx?wsdl/$metadata'.
    The request failed with HTTP status 4
    The message gets cut off in the "Web services found at this URL" text box. The Add Reference button never becomes active.

    Has anyone solved this problem?

    Cheers,

    Tim

  7. #7
    oudoulj is offline Junior Member White Belt
    Join Date
    Feb 2010
    Posts
    1

    Unhappy Re: 400: Bad Request for Virtual Earth Web Service

    Exact same error as auto_tim

    Using Windows 7 Ultimate 64-bit, IE8 and Visual Studio 2010 Beta 2.
    The "Add reference" button in the "Add Web Reference" box remains greyed out when trying to add any of the following urls

    https://staging.common.virtualearth....30/common.asmx
    https://staging.common.virtualearth....mmon.asmx?wsdl
    http://staging.common.virtualearth.net/find-30/common.asmx
    http://staging.common.virtualearth.net/find-30/common.asmx?wsdl

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Virtual Earth 6.2 and Web Service Webcast Recording
    By VirtualEarth MSDN Blog in forum Bing Maps Blogs & Tweets
    Replies: 0
    Last Post: 10-03-2008, 06:30 AM
  2. Geocoding with the Virtual Earth Web Service
    By VirtualEarth MSDN Blog in forum Bing Maps Blogs & Tweets
    Replies: 0
    Last Post: 09-30-2008, 06:30 AM
  3. Getting a Map with the Virtual Earth Web Service
    By VirtualEarth MSDN Blog in forum Bing Maps Blogs & Tweets
    Replies: 0
    Last Post: 09-26-2008, 06:22 PM
  4. Lancement de Virtual Earth Web Service et du Virtual Earth Map Control 6.2
    By Virtual Earth Europe in forum Bing Maps Blogs & Tweets
    Replies: 0
    Last Post: 09-25-2008, 03:22 AM
  5. Announcing The Virtual Earth Web Service and Virtual Earth Map Control 6.2
    By VirtualEarth MSDN Blog in forum Bing Maps Blogs & Tweets
    Replies: 0
    Last Post: 09-25-2008, 12:21 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127