Welcome to MapForums!

Register, sign in, or use Facebook Connect above to join in and participate in the forum.

When you are signed in, this message, the ads in this row, and the red-underlined link ads all go away.

Subscribe to receive our newsletter.
Subscribe Unsubscribe
Results 1 to 3 of 3

COM Add-in is "not a valid Office add-in." under Windows 7 64-bit

This is a discussion on COM Add-in is "not a valid Office add-in." under Windows 7 64-bit within the Development forums, part of the MapPoint Desktop Discussion category; Hopefully there is a simple solution for this. I have a COM Add-in created for MapPoint in VB6 / Windows ...

  1. #1
    Eric Frost's Avatar
    Eric Frost is offline Administrator Black Belt
    Join Date
    Jul 1992
    Posts
    5,094
    Blog Entries
    4

    COM Add-in is "not a valid Office add-in." under Windows 7 64-bit

    Hopefully there is a simple solution for this.

    I have a COM Add-in created for MapPoint in VB6 / Windows XP.

    When I try to add it under Tool | Com Add-ins in MapPoint on my Win7 64-bit laptop it reports that it is "not a valid Office add-in."

    Do I just need to compile it differently i.e. with some different options? Hoping I do not have to port it to VB.NET

    Eric
    ~ Order MapPoint MapPoint 2013 Here and Get Free Access to the MapForums Downloads ~
    ~~
    ~ Upgrade to Get Access to the MapForums Downloads ~

  2. #2
    Eric Frost's Avatar
    Eric Frost is offline Administrator Black Belt
    Join Date
    Jul 1992
    Posts
    5,094
    Blog Entries
    4

    Re: COM Add-in is "not a valid Office add-in." under Windows 7 64-bit <<-- ISSUE SOLVED!

    The solution was a lot easier than I even hoped.

    Actually the error is mis-leading (to me anyway) as it made me think the DLL was somehow not compatible with this operating system, it also happens with Vista, I think both 32 and 64 bit). I never used Vista so had not encountered the problem until Windows 7 64 bit. Note that Win7 32 bit does not have this problem.

    I was able to piece this together from posts by Richard Marsden and John Meyer in another thread. Richard says when using an installer, VB6 created DLL's are no problem. John Meyer suggested using > regsvr32.exe at the command line, which is exactly what needed to be done, but this is not the whole story. Actually, just doing this

    \> regsvr32 MyAddIn.dll

    still gives an error, but if you go to the Start Menu | Accessories and then right-click on "Command Prompt" and select Run As Administrator, then "cd" to the folder with your DLL and then run rgsvr32, this works perfectly. The COM Add-in now shows up in MapPoint.

    Hope this helps!
    Eric
    ~ Order MapPoint MapPoint 2013 Here and Get Free Access to the MapForums Downloads ~
    ~~
    ~ Upgrade to Get Access to the MapForums Downloads ~

  3. #3
    Eric Frost's Avatar
    Eric Frost is offline Administrator Black Belt
    Join Date
    Jul 1992
    Posts
    5,094
    Blog Entries
    4

    Regsvr32 Error 0x80004005

    Just thought I'd add that if you get the error code 0x80004005 it means the Command Prompt was not starting with Run As Administrator.

    Make sure you start the Command Prompt by going to the Start Menu, Accessories, and then right-click on the Command Prompt and select Run As Administrator.

    hope this helps!
    Eric
    ~ Order MapPoint MapPoint 2013 Here and Get Free Access to the MapForums Downloads ~
    ~~
    ~ Upgrade to Get Access to the MapForums Downloads ~

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Can I Display only -"X" and "Y"- and -"X" vs "Y"-
    By interner in forum Development
    Replies: 7
    Last Post: 06-15-2011, 03:28 PM
  2. Replies: 0
    Last Post: 03-16-2010, 05:16 PM
  3. Replies: 0
    Last Post: 11-12-2009, 08:30 AM
  4. "invalid argument; input argument 'latitude' is not a valid 'float' value"
    By hgeek in forum Bing Maps and MapPoint Web Service
    Replies: 9
    Last Post: 07-09-2008, 08:03 AM
  5. Do I need "Autoroute Europe", if I install "M
    By bigtail in forum MapPoint Desktop Discussion
    Replies: 1
    Last Post: 03-23-2004, 11:58 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114