Welcome to MapForums!

Register, sign in, or use Facebook Connect above to join in and participate in the forum.

When you are signed in, this message, the ads in this row, and the red-underlined link ads all go away.

Subscribe to receive our newsletter.
Subscribe Unsubscribe
Results 1 to 7 of 7

Delphi OleContainer problems

This is a discussion on Delphi OleContainer problems within the MapPoint Desktop Discussion forums, part of the Map Forums category; I've managed to get MapPoint 2002 working with Delphi using the OleContainer and i've sorted out accessing FindAddressResults and stuff ...

  1. #1
    pafreshney is offline Junior Member White Belt
    Join Date
    Aug 2002
    Posts
    1

    Delphi OleContainer problems

    I've managed to get MapPoint 2002 working with Delphi using the OleContainer and i've sorted out accessing FindAddressResults and stuff but....

    I ALWAYS get the MapPoint 2002 toolbars appearing within the form its located on if i put the OleContainer within a TPanel etc. or even a TBezel. Has anybody had these problems and can help me solve them.

    Thanks

    Paul

  2. #2
    Sheridan is offline Junior Member White Belt
    Join Date
    Mar 2003
    Posts
    4
    I'm having the same problem at this time.
    I placed a treeview on a panel left to the OleContainer Component. When i now connect to mappoint he overlais the treeview or any other component i will place on this form.

    Has anyone a sollution or workaround to prevent this effect.

    greets & thanks
    Sheridan

  3. #3
    rbarthels is offline Member Green Belt
    Join Date
    Nov 2002
    Posts
    52
    You can make disappear the toolbars with the Application property toolbars. Here you find a visible-property. The disadvantage when doing on runtime is that you can see the toolbars for a short-moment and all the panels move around. Very ugly.

    But when you switch the toolbars off in the MP-exe they don't appear.
    while initalizing the OLE-container.

  4. #4
    matt1168 is offline Junior Member Yellow Belt
    Join Date
    Jul 2003
    Posts
    14
    I had the same problem, It seems to be somthing to do with the ole containers align property. If it is set to anything but None it displays toolbars if the olecontainer is placed on the form. I got round this by placeing a Panel on the form and placing the olecontainer into the panel. Again if the panel's align property is set to anything but none you will get the toolbars, but if you set it to none and use the anchor propertys of the panel to handle resizing it should be ok.

  5. #5
    Anonymous is offline Senior Member Black Belt
    Join Date
    Jul 2002
    Posts
    5,137

    olecontainer&table

    I've been worked with delphi6 for 2 months,and i have a problem with olecontainer.
    I want to know how we can send the olecontainer objects to a field of table?

  6. #6
    Anonymous is offline Senior Member Black Belt
    Join Date
    Jul 2002
    Posts
    5,137

    ole&table

    I've been working with delphi6 for 2 months,and I have a problem with olecontainer.
    I want to know how we can send the olecontainer objects to a field of table?

  7. #7
    Anonymous is offline Senior Member Black Belt
    Join Date
    Jul 2002
    Posts
    5,137

    Delphi ActiveX Component

    I don't want this to appear as spam, but I understand your frustrations having tried to use the OleContainer with the same types of problems.

    We have now developed a wrapper for the ActiveX control that works with D5/7. Exposes a lot of properties and methods, and we are regularly adding new features.

    It is visible, interactive, with no toolbars - though you can have the legend and 'nearby' panes if you want.

    We've worked on this for months, it may be easier to use our component.

    http://www.gkconsulting.co.uk - look in the 'Products' section for a downloadable, compiled demo.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. MapPoint in OleContainer problem //BCB
    By tomek_tomek in forum MapPoint Desktop Discussion
    Replies: 3
    Last Post: 08-16-2005, 03:54 PM
  2. Mappoint in OleContainer problem //Delphi
    By Anonymous in forum MapPoint Desktop Discussion
    Replies: 6
    Last Post: 01-08-2005, 02:03 PM
  3. Delphi OleContainer Resize Problem.
    By Sheridan in forum MapPoint Desktop Discussion
    Replies: 5
    Last Post: 12-19-2003, 06:50 AM
  4. ShowModal hides form with MP in olecontainer
    By Anonymous in forum MapPoint Desktop Discussion
    Replies: 0
    Last Post: 05-13-2003, 11:50 AM
  5. Problems with Dutch ZIP codes (bug?) (Delphi code provided)
    By schuchhardp in forum MapPoint Desktop Discussion
    Replies: 2
    Last Post: 11-28-2002, 04:37 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66