Welcome to MapForums!

Register, sign in, or use Facebook Connect above to join in and participate in the forum.

When you are signed in, this message, the ads in this row, and the red-underlined link ads all go away.

Subscribe to receive our newsletter.
Subscribe Unsubscribe
Results 1 to 3 of 3

Failed to optimise waypoints

This is a discussion on Failed to optimise waypoints within the Development forums, part of the MapPoint Desktop Discussion category; Hi, in a VB.Net program, I am adding several waypoints, and then doing a 'waypoints.optimize' and getting an error message ...

  1. #1
    petevick is offline Junior Member White Belt
    Join Date
    Nov 2007
    Posts
    5

    Failed to optimise waypoints

    Hi,
    in a VB.Net program, I am adding several waypoints, and then doing a 'waypoints.optimize' and getting an error message "Failed to optimise waypoints"

    Using Mappoint, I can put the same postcodes into a spreadsheet, import them, and add them as stops, and then optimize and it works fine.

    Anyone got any ideas please?

    Thanks

    Pete

  2. #2
    petevick is offline Junior Member White Belt
    Join Date
    Nov 2007
    Posts
    5

    Re: Failed to optimise waypoints

    Hi,
    ok - I seem to have got a little bit further. I am trying to throw postcodes and optimise and calculate a route.

    If I have a start point of BL34RX and an end point of BB12QS then everything is ok.

    If I then add a stop of WN25DA it still appears to optimise, and I have 3 waypoints

    ?mproute.Waypoints(1).Type
    geoWaypointStart {1}
    ?mproute.Waypoints(2).Type
    geoWaypointStop {2}
    ?mproute.Waypoints(3).Type
    geoWaypointEnd {3}

    But my directions seem to miss out my stop...

    09:00 Depart Start Point BL34RX
    09:00 At Drop 1 at WN2 5DA, turn RIGHT (West) onto Beaumont Drive
    09:00 Turn LEFT (South) onto Armadale Road
    09:00 Turn RIGHT (West) onto Local road(s)
    09:01 Turn LEFT (South) onto A58 [Beaumont Road]
    09:03 Turn RIGHT (South-West) onto A58 [Wigan Road]
    09:04 At roundabout, take the THIRD exit onto Ramp M61 / Preston / Chorley
    09:04 Merge onto M61
    09:15 At exit 9, keep LEFT onto Ramp M65 / Burnley / Blackburn / Preston South
    09:16 At roundabout, take the FOURTH exit onto Ramp M65 / Burnley / Blackburn
    09:17 Merge onto M65 ....
    09:25 Turn LEFT (North) onto Local road(s)
    09:25 Arrive End Point BB12QS


    Any ideas what I am missing please?

    Thanks

    Pete

  3. #3
    petevick is offline Junior Member White Belt
    Join Date
    Nov 2007
    Posts
    5

    Re: Failed to optimise waypoints

    Sorted - my fault for supplying incorrect lat/long for stop

    Thanks

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. MapPoint Addin failed to load
    By satrapu in forum MapPoint Desktop Discussion
    Replies: 0
    Last Post: 11-03-2005, 03:40 AM
  2. Assertion failed error
    By Radar in forum MapPoint Desktop Discussion
    Replies: 2
    Last Post: 10-01-2005, 05:35 AM
  3. MapPoint failed to load...
    By eltrigo in forum MapPoint Desktop Discussion
    Replies: 1
    Last Post: 08-16-2005, 03:27 PM
  4. link to the Access DB failed
    By Anonymous in forum MapPoint Desktop Discussion
    Replies: 0
    Last Post: 11-16-2004, 09:55 AM
  5. Mappoint Failed to load error
    By starbuck in forum MapPoint Desktop Discussion
    Replies: 5
    Last Post: 11-08-2004, 06:37 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87