Welcome to MapForums!

Register, sign in, or use Facebook Connect above to join in and participate in the forum.

When you are signed in, this message, the ads in this row, and the red-underlined link ads all go away.

Subscribe to receive our newsletter.
Subscribe Unsubscribe
Results 1 to 5 of 5

I am currently working with the MapPoint 2002 Tria....

This is a discussion on I am currently working with the MapPoint 2002 Tria.... within the MapPoint Desktop Discussion forums, part of the Map Forums category; I am currently working with the MapPoint 2002 Trial. I want to utilize MapPoint in an Access database. I can ...

  1. #1
    Anonymous is offline Senior Member Black Belt
    Join Date
    Jul 2002
    Posts
    5,137
    I am currently working with the MapPoint 2002 Trial. I want to utilize MapPoint in an Access database. I can add a MapPoint control to the form and create buttons to do different functions. However, after testing the form, if I go back to design view, I get a message saying "There is no control in this object." and the MapPoint control on my form gets deleted. Any help would be appreciated.

  2. #2
    Anonymous is offline Senior Member Black Belt
    Join Date
    Jul 2002
    Posts
    5,137
    I'm using Access 2002 on a Windows XP machine. I've tried it with and without service pack 1 for Office XP installed.

  3. #3
    Anonymous is offline Senior Member Black Belt
    Join Date
    Jul 2002
    Posts
    5,137
    Me too. I have to be careful to make code changes and save before returning to the form then close the form and then reopen to test.

  4. #4
    Anonymous is offline Senior Member Black Belt
    Join Date
    Jul 2002
    Posts
    5,137
    Greg, I had the same problem. Have you overcome it yet?

    I used a code sample which works with an image control on the Access form, pasting the contents of a MapPoint Object into the image.

    Email me for further info or to share progress at wellermatt@hotmail.com.

    Code Sample (sorry it is untidy!):

    Private Sub Form_Load()

    SetObjects
    ReloadMap ("None")

    End Sub

    Sub SetObjects()

    Set oApp = CreateObject("Mappoint.Application")
    Set oMap = oApp.OpenMap("c:\matt\renault\CUstom Territories.ptm") 'Create a new map

    End Sub
    Sub ReloadMap(PCode)

    Dim oPush As Object, oLoc As Object

    Set oLoc = oMap.Find(PCode)

    'get address from PostCode

    If Not oLoc Is Nothing Then 'Check to see if the first address was found.
    Set oPush = oMap.AddPushpin(oLoc) 'Place a pushpin on the map
    'add some more details to the pushpin and display the balloon
    oPush.BalloonState = geoDisplayBalloon
    oMap.ZoomIn
    oPush.Goto
    oMap.Saved = True
    'Zoom in so that the entire map with directions is viewed
    oMap.CopyMap 'Copy the map to the clipboard
    img.Visible = True 'Change the image place holder in the Access form to visible
    img.Action = acOLEPaste
    End If

    End Sub


    Sub RefreshMap()
    oMap.Saved = True
    'Zoom in so that the entire map with directions is viewed
    oMap.CopyMap 'Copy the map to the clipboard
    img.Visible = True 'Change the image place holder in the Access form to visible
    img.Action = acOLEPaste
    End Sub


    Private Sub cmdPanEast_Click()
    oMap.Pan (geoEast)
    RefreshMap
    End Sub


    Private Sub cmdPanNorth_Click()
    oMap.Pan (geoNorth)
    RefreshMap
    End Sub


    Private Sub cmdPanSouth_Click()
    oMap.Pan (geoSouth)
    RefreshMap
    End Sub


    Private Sub cmdPanWest_Click()
    oMap.Pan (geoWest)
    RefreshMap
    End Sub


    Private Sub cmdZoomIn_Click()
    oMap.ZoomIn
    RefreshMap
    End Sub


    Private Sub cmdZoomOut_Click()
    oMap.ZoomOut
    RefreshMap
    End Sub




  5. #5
    Anonymous is offline Senior Member Black Belt
    Join Date
    Jul 2002
    Posts
    5,137
    I'm not familiar with this issue, what version of Access are you using? The trial is fully-functional so there shouldn't be an issue with that.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Got Mappoint ActiveX working in Delphi 5
    By lynx in forum MapPoint Desktop Discussion
    Replies: 9
    Last Post: 04-08-2010, 03:55 PM
  2. When working with mappoint and coping to word how ....
    By Anonymous in forum MapPoint Desktop Discussion
    Replies: 1
    Last Post: 06-28-2002, 08:20 AM
  3. Hi there. Working with MapPoint 2002, Is it pos....
    By Anonymous in forum MapPoint Desktop Discussion
    Replies: 1
    Last Post: 06-25-2002, 09:36 AM
  4. I am working with MapPoint Europe 2002. How can I ....
    By Anonymous in forum MapPoint Desktop Discussion
    Replies: 1
    Last Post: 06-24-2002, 09:36 AM
  5. I am working with Mappoint in Pakistan and I want ....
    By Anonymous in forum MapPoint Desktop Discussion
    Replies: 1
    Last Post: 06-22-2002, 09:02 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83