I have a product which has the MS MP ActiveX control included in the program. It is the 2002 version of the MP control.
Installation is accomplished (theoretically) through a hook which is added to the Visual Basic PDWizard Setup project which calls an executable called mpcsetup.exe. Mpcsetup.exe then takes over (for a few moments) and installs the MP ActiveX control. This has always worked like a charm.
This time we are installing on to a 'new' 64 bit Athlon processor and the mpcsetup.exe hangs at (about) one minute remaining. There is no error message, and we have tried waiting it out but fifteen minutes did not do it.
A three finger salute reveals that the Visual Basic 6 Setup program has stopped responding. Ending it does not let the MP ActiveX control setup continue. Also running the MPCSetup.exe program by itself causes the same problem.
I can't seem to find much support info for 64 bit issues or the 2002 version of MapPoint. We are currently upgrading our program to use the MapPoint 2004 version of the ActiveX control ...