Welcome to MapForums!

Register, sign in, or use Facebook Connect above to join in and participate in the forum.

When you are signed in, this message, the ads in this row, and the red-underlined link ads all go away.

Subscribe to receive our newsletter.
Subscribe Unsubscribe
Results 1 to 2 of 2

mappoint 2002 in vb.net on a mdi child

This is a discussion on mappoint 2002 in vb.net on a mdi child within the MapPoint Desktop Discussion forums, part of the Map Forums category; I am trying to use a mappoint 2002 control on a mdi child form in vb.net and always get "An ...

  1. #1
    superdave is offline Junior Member White Belt
    Join Date
    Sep 2002
    Posts
    2

    mappoint 2002 in vb.net on a mdi child

    I am trying to use a mappoint 2002 control on a mdi child form in vb.net and always get

    "An unhandled exception of type 'System.ArgumentException' occurred in axinterop.mappoint.dll
    Additional information: MapPoint failed to load. The cause of this failure is unknown."

    The error occurs at the .openmap method which is called on the form load.

    This is the code used to launch the form
    Dim fMap As New frmMap()
    fMap.MdiParent = Me
    fMap.Show()

    If I comment out the 'fMap.MdiParent = Me' it loads fine and displays the map.

    I have seen some other people in user group postings with the same problem in vb.net and C#.net , but , no one with a fix???

  2. #2
    superdave is offline Junior Member White Belt
    Join Date
    Sep 2002
    Posts
    2

    Working Now

    Ok,

    I was able to get this working now by opening the map in a timer after the form was loaded. For some reason in vb.net on an mdi child it would
    not work from the form load.

    Now I am having the same problem I was having in VB6. Mappoint keeps blowing its container. When the form loads up, the mappoint application is loaded outside of its control container. If I unload the form then load it back Mappoint closes and it works fine (inside the container). The form loads fine every other time until I reboot the machine. I have reinstalled mappoint on 2 machines and still have the same problem.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. I am currently using MapPoint 2002. Is there a wa....
    By Anonymous in forum MapPoint Desktop Discussion
    Replies: 3
    Last Post: 04-08-2010, 07:59 AM
  2. Mappoint 2002 with c#
    By dave_behaving_badly in forum MapPoint Desktop Discussion
    Replies: 0
    Last Post: 08-19-2003, 06:49 AM
  3. Help Using Mappoint 2002 As A COM in .Net
    By Anonymous in forum MapPoint Desktop Discussion
    Replies: 0
    Last Post: 05-21-2003, 09:31 PM
  4. MapPoint 2002
    By Anonymous in forum MapPoint Desktop Discussion
    Replies: 2
    Last Post: 10-29-2002, 11:25 AM
  5. Hello. I am using MapPoint 2002. I am doing a lot ....
    By Anonymous in forum MapPoint Desktop Discussion
    Replies: 1
    Last Post: 06-24-2002, 01:04 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83