Welcome to MapForums!

Register, sign in, or use Facebook Connect above to join in and participate in the forum.

When you are signed in, this message, the ads in this row, and the red-underlined link ads all go away.

Subscribe to receive our newsletter.
Subscribe Unsubscribe
Results 1 to 3 of 3

MapPoint "There was a problem opening ..." With Or

This is a discussion on MapPoint "There was a problem opening ..." With Or within the MapPoint Desktop Discussion forums, part of the Map Forums category; I'm developing an application for our sales reps that replicates customer information to a local Oracle Lite (10.2.0.1 WIN32) database. ...

  1. #1
    eric.hill is offline Junior Member White Belt
    Join Date
    Apr 2006
    Posts
    5

    MapPoint "There was a problem opening ..." With Or

    I'm developing an application for our sales reps that replicates customer information to a local Oracle Lite (10.2.0.1 WIN32) database.

    We're planning to use MapPoint to map some of this data for the reps.

    Since MapPoint only opens a UDL file or Access database, I created a simple UDL file on my desktop that uses the stock Micorosft OLEDB to ODBC driver to connect to Oracle Lite. The "Test Connection" succeeds without error.

    When I open MapPoint 2004 and attempt to link data to the UDL file, I get a list of tables in my replicated data set. I choose a table, click next, and then get an error (within about 2 seconds) "There was a problem opening [the_olite_udl_file.udl], MY_TABLE_NAME".

    I can create an empty Access database and link to the same exact data just fine, then use MapPoint to link to the access database successfully.

    In summary, Excel and Access can successfully link and query data from the Lite database. msql connects to Lite and can query as well. MapPoint can successfully link and query an Access database. MapPoint can successfully connect to a full Oracle 10g database through the Oracle OLEDB provider. MapPoint fails to connect to the Lite ODBC driver with the above non-descript error message.

    I posted this same request on the Oracle Lite forum
    at article 37629 in case this winds up being and Oracle Lite issue.

  2. #2
    Eric Frost's Avatar
    Eric Frost is offline Administrator Black Belt
    Join Date
    Jul 1992
    Posts
    5,094
    Blog Entries
    4
    I have not worked with Oracle but have do several apps with MapPoint hitting off Access and MS SQL Server that worked fine. Would a work-around be to periodically dump the data to Access or sync with a MS SQL Server database?
    Eric
    ~ Order MapPoint MapPoint 2013 Here and Get Free Access to the MapForums Downloads ~
    ~~
    ~ Upgrade to Get Access to the MapForums Downloads ~

  3. #3
    eric.hill is offline Junior Member White Belt
    Join Date
    Apr 2006
    Posts
    5

    Alternatives

    Hi Eric - thanks for the reply.

    Quote Originally Posted by Eric Frost
    Would a work-around be to periodically dump the data to Access or sync with a MS SQL Server database?
    I have created an Access database that simply contains a couple of links to the Oracle Lite database, and am able to query live data from MapPoint through the Access database. This is an acceptible work-around, however I'd really like to know why I have to introduce another layer of complexity to get MapPoint to work.

    It's also possible that it's not a MapPoint problem since MapPoint works through Access, SQL Server, and Oracle (Standard), but doesn't work with Oracle Lite, but I find it odd that MapPoint seems to be the only application that WON'T talk to Oracle Lite. I've attached to the Lite database with Access, Excel, a Delphi application, and a Java application, and all of them work perfectly fine...

    I'd just like to get a definitive answer on this, specifically whether it's MapPoint or Oracle Lite that is at fault.

    Do you have access to MapPoint 2006? Does anyone? If so, would you be willing to work with me on testing it with a sample of my data?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. MapPoint 2004 Active-X control: how to "bump" pus
    By citrix_99301 in forum MapPoint Desktop Discussion
    Replies: 3
    Last Post: 03-18-2006, 03:50 AM
  2. Big problem with "get_item" method :((
    By Elbarto in forum MapPoint Desktop Discussion
    Replies: 3
    Last Post: 03-09-2006, 03:40 PM
  3. Mappoint exception "Call was rejected by callee"
    By jliao81 in forum MapPoint Desktop Discussion
    Replies: 1
    Last Post: 06-03-2005, 08:53 AM
  4. Do I need "Autoroute Europe", if I install "M
    By bigtail in forum MapPoint Desktop Discussion
    Replies: 1
    Last Post: 03-24-2004, 12:58 AM
  5. "Microsoft Mappoint" writing and Pushpin Highligth
    By feanor in forum MapPoint Desktop Discussion
    Replies: 0
    Last Post: 03-12-2003, 05:47 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27