Welcome to MapForums!

Register, sign in, or use Facebook Connect above to join in and participate in the forum.

When you are signed in, this message, the ads in this row, and the red-underlined link ads all go away.

Subscribe to receive our newsletter.
Subscribe Unsubscribe
Results 1 to 7 of 7

[Pb] : VB6 + Service

This is a discussion on [Pb] : VB6 + Service within the MapPoint Desktop Discussion forums, part of the Map Forums category; Hello, I developped an VB6 executable to manage my customer's datas. This customer needs now a service instead a .EXE. ...

  1. #1
    Vincent BENNER's Avatar
    Vincent BENNER is offline Member Yellow Belt
    Join Date
    Sep 2002
    Posts
    44

    [Pb] : VB6 + Service

    Hello,

    I developped an VB6 executable to manage my customer's datas. This customer needs now a service instead a .EXE.

    I read on the Msdn that a VB6 -> service transformation wasn't a good idea but that it could work.

    I transformed my .exe including a NTSVC.ocx control and including all the necessary code.

    When I start the service, I've got a (so) little problem : the MapPointControl.ocx isn't loaded !!!!


    Me.ctrlMAPPOINT.NewMap (geoMapEurope)
    While Me.ctrlMAPPOINT.ReadyState <> READYSTATE_COMPLETE
    DoEvents
    Wend

    Any idea ?

    Regards,

  2. #2
    Wilfried is offline Senior Member Black Belt
    Join Date
    Nov 2004
    Location
    Belgium
    Posts
    2,433
    Hi,

    I really dont know, have to make a service myself with mappoint but thats for within a few mondts if it go true.

    I should try to debug in steps. First of all maybe soemthing to do with the service controls you use. So make a program (not a service) that does not do mutch more than create and destroy a mappoint component. To run it as a service just start it with the windows scheduler as service. If that works (you can log things to a file in the testprogram) then you know it has nothing to do with then mappoint control.

    If it doesnt, maybe try to register the ocx in the service, by calling winapi ExecAndWait to run RegSrv32.exe but first things first

  3. #3
    Anonymous is offline Senior Member Black Belt
    Join Date
    Jul 2002
    Posts
    5,137

    OCX Issue

    I am also experiencing a similar problem. The custom OCX (created by me) runs fine as long as the full mappoint software is installed in the client machine, If I just install the runtime ActiveX installation, the program crashes. This blows away distributing the runtime liceses with Mappoint Installtion.

    Please help.

  4. #4
    nandhini is offline Junior Member White Belt
    Join Date
    Jan 2005
    Posts
    3

    OCX Issue

    I am also experiencing a similar problem. The custom OCX (created by me) runs fine as long as the full mappoint software is installed in the client machine, If I just install the runtime ActiveX installation, the program crashes. This blows away distributing the runtime liceses with Mappoint Installtion.

    Please help.

  5. #5
    Anonymous is offline Senior Member Black Belt
    Join Date
    Jul 2002
    Posts
    5,137
    Hello,

    I've read this topic with a high interest. Should I understand that I've to distribute my software with the ActiveX only and that the customer have to purchase a licence but without install it ?

    How it will happens to geocode the adresses ?

    Regards,

    Vincent BENNER

  6. #6
    Wilfried is offline Senior Member Black Belt
    Join Date
    Nov 2004
    Location
    Belgium
    Posts
    2,433
    Hi,

    Quote Originally Posted by Anonymous
    Should I understand that I've to distribute my software with the ActiveX only and that the customer have to purchase a licence but without install it ?
    No Mappoint does have to be installed. I think you can do a runtime installation (that's what I understeadn of this topic).

  7. #7
    nandhini is offline Junior Member White Belt
    Join Date
    Jan 2005
    Posts
    3
    I still don't have any solution. If you install a runtime installation and your software (exe version), the program will work fine, if you have embedded your mappoint.ocx with in your own ocx, it will crash. I think it is EULA issue.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. mappoint web service
    By Anonymous in forum Bing Maps and MapPoint Web Service
    Replies: 5
    Last Post: 12-02-2009, 10:48 AM
  2. Speed of the service
    By sbedin in forum Bing Maps and MapPoint Web Service
    Replies: 0
    Last Post: 12-21-2004, 11:13 AM
  3. Web service with delphi
    By Anonymous in forum Bing Maps and MapPoint Web Service
    Replies: 1
    Last Post: 11-10-2004, 09:43 AM
  4. NT Service and MP
    By Anonymous in forum MapPoint Desktop Discussion
    Replies: 2
    Last Post: 01-23-2003, 03:31 PM
  5. I am trying to indicate service areas by using a s....
    By Anonymous in forum MapPoint Desktop Discussion
    Replies: 1
    Last Post: 08-30-2001, 07:43 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59