Welcome to MapForums!

Register, sign in, or use Facebook Connect above to join in and participate in the forum.

When you are signed in, this message, the ads in this row, and the red-underlined link ads all go away.

Subscribe to receive our newsletter.
Subscribe Unsubscribe
Results 1 to 7 of 7

Printout method not working

This is a discussion on Printout method not working within the MapPoint Desktop Discussion forums, part of the Map Forums category; I have been using the Trial version of MP 2002 to test the feasibilty of a project running MP from ...

  1. #1
    AndyYule is offline Junior Member White Belt
    Join Date
    Jan 2003
    Posts
    8

    Printout method not working

    I have been using the Trial version of MP 2002 to test the feasibilty of a project running MP from within Visual Foxpro.

    Everything seems to work fine so far apart from the Printout method.
    When I call the method on a PC running XP Pro I get the error - Ole lDispatch exception code 0 from Mappoint.Application.EU.9 The RPC Server is unavailable.

    When running exactly the same code on a Windows 98SE system I receive no error, but only the border of the map is printed (a square box with the scale on it) but no map!

    Any ideas?

    Thanks,
    Andy

  2. #2
    AndyYule is offline Junior Member White Belt
    Join Date
    Jan 2003
    Posts
    8

    Same problem occurs in VB as well...

    Just to check that it's not Visual Foxpro - I did the same test in VB, with the same results.

    Andy

  3. #3
    John Meyer's Avatar
    John Meyer is offline Senior Member Blue Belt
    Join Date
    Jul 2002
    Posts
    478
    If you can post you Printout code we can see if something looks out of place.

  4. #4
    AndyYule is offline Junior Member White Belt
    Join Date
    Jan 2003
    Posts
    8

    Code Example

    The initialisation of the form just does a

    thisform.olemappoint.newmap(2) to create a map

    The object reference to the form is Mapping, the form contains the olemappoint object

    So I can issue the line
    Mapping.olemappoint.activemap.printout()

    That's it!
    Thanks,
    Andy

  5. #5
    John Meyer's Avatar
    John Meyer is offline Senior Member Blue Belt
    Join Date
    Jul 2002
    Posts
    478
    Very odd problem for sure. I can only think of two things to try at this point. You may have already tried them but if not, give em a try, can't hurt...

    1. Try printing to a completly different printer, printer drivers can do weird things sometimes.

    2. Try using the printout method with all the parameters filled in.

    objMap.PrintOut , "Test Map", 1, _
    geoPrintMap, geoPrintQualityNormal, geoPrintLandscape, _
    True, False, True, False

  6. #6
    AndyYule is offline Junior Member White Belt
    Join Date
    Jan 2003
    Posts
    8

    Full (Non-trial) version works!

    Well get this!

    I decided to purchase a full version of MP and have installed it on my systems. (You must remove the Trial version first). But it is now printing OK on both systems.

    FYI this is what I did....

    I first tried it on the 98SE system and that worked fine, I then removed the full version from my 98SE system and re-installed the Trial version - it seems to have fixed the problem!

    Next idea - 'the Trial version did not install correct the first time' - so on my XP Pro system I reinstalled the Trial again.... problem still exists... Installed the full version - problem gone!!!

    The versions on both the Trial and the full version were MP 2002 (09.00.16.2001)


    The Trial is supposed to be 100% the same, but with the time limit!

    Regards,
    Andy

  7. #7
    John Meyer's Avatar
    John Meyer is offline Senior Member Blue Belt
    Join Date
    Jul 2002
    Posts
    478
    Andy,

    Thanks for the update, I'm glad it worked out in the end. I wouldn't be suprised if the folks from the MapPoint Team keep an eye on this forum so maybe they will make sure it is fixed in the next release of MapPoint?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Labelling pushpins in a printout
    By Anonymous in forum MapPoint Desktop Discussion
    Replies: 0
    Last Post: 08-13-2004, 05:28 PM
  2. PrintOut method with MapPoint ActiveX control?!!
    By TheJudge in forum MapPoint Desktop Discussion
    Replies: 3
    Last Post: 04-13-2004, 05:35 PM
  3. FindAddressResults not always working?
    By Anonymous in forum MapPoint Desktop Discussion
    Replies: 1
    Last Post: 09-10-2003, 05:25 AM
  4. plz help me : working on GPS system
    By shami in forum MapPoint Desktop Discussion
    Replies: 0
    Last Post: 07-17-2003, 05:20 AM
  5. Map PrintOut method
    By blackmap in forum MapPoint Desktop Discussion
    Replies: 1
    Last Post: 01-10-2003, 02:04 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83