Welcome to MapForums!

Register, sign in, or use Facebook Connect above to join in and participate in the forum.

When you are signed in, this message, the ads in this row, and the red-underlined link ads all go away.

Subscribe to receive our newsletter.
Subscribe Unsubscribe
Results 1 to 4 of 4

Problem with map_selectionchange

This is a discussion on Problem with map_selectionchange within the MapPoint Desktop Discussion forums, part of the Map Forums category; I have an application where the user can move pushpins. When they do, I calculate its new position using the ...

  1. #1
    Anonymous is offline Senior Member Black Belt
    Join Date
    Jul 2002
    Posts
    5,137

    Problem with map_selectionchange

    I have an application where the user can move pushpins. When they do, I calculate its new position using the poldSelection in the SelectionChange event, and save the position into the database.
    BUT I have found that if the next item clicked is overlapping pushpins (so you get a list of options) and you click "Cancel" then the SelectionChange event is not triggered so the change of position is lost.

    Any ideas? Where else can I detect the pin movement? Or force the SelectionChange event?

    Many thanks, Stuart

  2. #2
    1.21Gigawatts is offline Junior Member White Belt
    Join Date
    Apr 2005
    Posts
    8
    I have not been able to reproduce this behavior. I select a pushpin by itself. Then if I click on a group pushpins and get the selection menu, click cancel, SelectionChange gets fired. NewSelection is null, but OldSelection is the pushpin that I first selected. Are you using the control or the application object?

  3. #3
    Anonymous is offline Senior Member Black Belt
    Join Date
    Jul 2002
    Posts
    5,137

    Problem with map_selectionchange

    I am using the TBMapControl_SelectionChange in the program. This is with the "Mappoint Control 9.0" included in the VB project.

  4. #4
    Anonymous is offline Senior Member Black Belt
    Join Date
    Jul 2002
    Posts
    5,137

    Sorted!

    Thanks for you input, I have found the problem which was a typo in
    the code in the SelectionChaneg section!

    Cheers, Stuart

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25