Welcome to MapForums!

Register, sign in, or use Facebook Connect above to join in and participate in the forum.

When you are signed in, this message, the ads in this row, and the red-underlined link ads all go away.

Subscribe to receive our newsletter.
Subscribe Unsubscribe
Results 1 to 3 of 3

Pushpins work fine in MP 2004, but not so well in IE 6.0

This is a discussion on Pushpins work fine in MP 2004, but not so well in IE 6.0 within the MapPoint Desktop Discussion forums, part of the Map Forums category; Greetings MP2K users and MP pushpin experts, I am a newbie to MapPoint 2004 and the MP2K forum. I am ...

  1. #1
    alben is offline Junior Member White Belt
    Join Date
    Mar 2006
    Posts
    2

    Pushpins work fine in MP 2004, but not so well in IE 6.0

    Greetings MP2K users and MP pushpin experts,

    I am a newbie to MapPoint 2004 and the MP2K forum. I am able to generate maps in MP 2004, import data sets from Excel to generate maps and then save the maps as web pages.

    I have then uploaded the files to display the maps as web pages to my
    website and the maps do show up on my IE 6.0 browser.

    Here is my problem:

    When I am in MapPoint 2004, I have generated a map with 60 pushpins and each pushins does show up on the map and the balloon information also displays if you click on each pushpin...but only in MapPoint 2004.

    Then I save that map as a web page and then upload the files to my website and the map and all the pushpins display and show up fine on the webpage.

    But when you try to click on any pushpin on the map webpage in IE 6.0, the pushpins do not act as a link to the pushpin's balloon info.

    When I import the data sets from Excel the first column is the unique
    identifyer for each row of data. Each row has a different number as a unique identifyer.

    I think I am close, but I am missing some command or setting.

    I had some success, getting pushpins with hyperlinks in the info balloon to work on saved web pages when the map was being displayed in IE 6.0.

    Pushins on a map, will work fine in MapPoint 2004 . . . the pushpin info
    balloon with name and address will display when you click on the pushpin,
    when running in MapPoint 2004.

    But when that map is saved as a webpage and then displayed in IE 6.0, the pushins will only respond if a hyperlink is in the pushpin's info balloon.

    All the pushpins with only name and address and no hyperlink, will only work in MapPoint 2004, and not work in the saved web page when diplayed in IE 6.0.

    The pushins that worked on the saved web page had to have a hyperlink in the pushpin's info balloon . . . and then you were sent directly to the hyperlink web page. . . no balloon info name or address is displayed.

    In MapPoint 2004, when you clicked on the pushpins with hyperlinks, the
    pushpin's name, address and hyperlink would be displayed in the pushpin
    balloon. But you were not sent directly to the hyperlink, as you would be
    with a saved web page in a browser.

    I saved the map as a webpage with only my pushins and again saved another map as a webpage with my pushpins and all the POI's showing.

    In both cases the pushpin's with only name and address information did not respond or display when you clicked on the individual pushpin on a map saved as a web page and displayed in IE 6.0.

    But in both of those cases the pushpin's with hyperlinks did send you to the web page of the hyperlink when clicked on in the browser.

    I am a MapPoint newbie, and a html novice, but I can generate a map with pushpins and post it to my website, without everything blowing up.

    I posted this on the MSDN MapPoint forum and so far I do not have a solution . . . I am hoping that the MP2K forum will come to my rescue.

    Thanks for any help on this.

    alben

  2. #2
    Winwaed's Avatar
    Winwaed is offline Mapping-Tools.com Black Belt
    Join Date
    Feb 2004
    Location
    Irving,Texas
    Posts
    1,859
    Blog Entries
    60
    When you save the map as a web page, you are only saving a static picture of the current view. Ie. it is a bit like printing the map to paper.

    To have a working map on a webpage would require a lot of map data -ie. the two disks you used to install MapPoint!


    Richard
    Winwaed Software Technology LLC
    http://www.winwaed.com
    See http://www.mapping-tools.com for MapPoint Tools

  3. #3
    alben is offline Junior Member White Belt
    Join Date
    Mar 2006
    Posts
    2
    Thanks Richard,

    I came up with a way of getting hyperlinked pushins to display info that works well in MP 2004.

    Currently I have maps saved as web pages that are zoomed out and have too many pushpins to use text boxes. And I don't want hyperlinked pushpins on web page map with dozens of pushpins.

    Now on the same map web page I will include a link to another map page with a closer view that will include hyperlinked pushpins.

    On this zoomed in map web page, where I want to link each location to more info . . by using a zoomed in view of the map, I can then use a text box to display the name of each location on the map.

    Then next to each text box, I will place a pushpin that is hyperlinked to another web page on my website to display more detailed information and addition hyperlinks.

    I will use the MP pushpin symbol that looks like, "a comic book text balloon" . . . the MP 2004 pushpin symbol number is 068, and have that pushin setup as a hyperlink on the saved web page.

    Another good pushpin symbol would be the, "Information Logo" pushpin symbol that has a MP 2004 number of 095.

    It works for me.

    Thanks for the reply.

    alben

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. ActiveX control fails in VS2005, but was fine in VS2003
    By jtowell in forum MapPoint Desktop Discussion
    Replies: 7
    Last Post: 11-23-2006, 03:42 PM
  2. MP 2004 IS SHOWING PUSHPINS IN WRONG LOCATION
    By MAKAZA in forum MapPoint Desktop Discussion
    Replies: 7
    Last Post: 11-22-2005, 03:47 PM
  3. MAPPOINT working fine with OLAP cubes
    By Tonito el Galo in forum MapPoint Desktop Discussion
    Replies: 0
    Last Post: 10-26-2005, 04:08 AM
  4. Failed to see pushpins in MapPoint 2004
    By chaua in forum MapPoint Desktop Discussion
    Replies: 8
    Last Post: 06-24-2005, 02:40 AM
  5. Get Street Adrress doesn't work on MapPoint 2004 Europe
    By Van in forum MapPoint Desktop Discussion
    Replies: 3
    Last Post: 01-20-2005, 03:14 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96