Welcome to MapForums!

Register, sign in, or use Facebook Connect above to join in and participate in the forum.

When you are signed in, this message, the ads in this row, and the red-underlined link ads all go away.

Subscribe to receive our newsletter.
Subscribe Unsubscribe
Results 1 to 5 of 5

Random Link update failed error when doing UpdateLink method

This is a discussion on Random Link update failed error when doing UpdateLink method within the MapPoint Desktop Discussion forums, part of the Map Forums category; I randomly get a "Link update failed' error when doing dataset.updatelink. If I do the update again without changing anything ...

  1. #1
    stephenmillington is offline Member Yellow Belt
    Join Date
    Jun 2004
    Posts
    40

    Random Link update failed error when doing UpdateLink method

    I randomly get a "Link update failed' error when doing dataset.updatelink. If I do the update again without changing anything it then works. Has anyone else experienced this and if so why would it be doing this and is there a solution?

  2. #2
    calv1ns's Avatar
    calv1ns is offline Member Green Belt
    Join Date
    Mar 2005
    Posts
    91

    On Error Handle

    Hey Stephen

    I'd trap the error and then retry the update a set number of times. If you fail the update like three times then display your own message. This isn't pretty but it will work.

    Ciao,
    Calv1ns

  3. #3
    stephenmillington is offline Member Yellow Belt
    Join Date
    Jun 2004
    Posts
    40
    Hi

    Thanks for that. I had thought of doing that but I am a bit concerned as to why the update failed in the first place. Have you experienced this problem yourself?

  4. #4
    calv1ns's Avatar
    calv1ns is offline Member Green Belt
    Join Date
    Mar 2005
    Posts
    91
    To be honest Stephen I'm not the hottest of hot shot programmers. I get all sorts of weird errors here and there. No, I do not recall the specific error you mentioned. But I do often get errors that I work on for hours then only to find they myseriously dissappear when I re-boot the computer. It is all just part of being a Windows programmer isn't it?

    Ciao,
    Calv1ns

  5. #5
    stephenmillington is offline Member Yellow Belt
    Join Date
    Jun 2004
    Posts
    40
    I guess so and I also get the impression the OLE link to Mappoint isn't completely stable either

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. MP2004 Link Update Failed -2147190772
    By AndyWood in forum MapPoint Desktop Discussion
    Replies: 2
    Last Post: 10-13-2005, 06:06 PM
  2. Assertion failed error
    By Radar in forum MapPoint Desktop Discussion
    Replies: 2
    Last Post: 10-01-2005, 05:35 AM
  3. link to the Access DB failed
    By Anonymous in forum MapPoint Desktop Discussion
    Replies: 0
    Last Post: 11-16-2004, 09:55 AM
  4. Run-time error 'Method 'UpdateLink' object 'DataSet' failed
    By Anonymous in forum MapPoint Desktop Discussion
    Replies: 0
    Last Post: 09-18-2003, 04:53 PM
  5. UpdateLink method
    By Maverick in forum MapPoint Desktop Discussion
    Replies: 1
    Last Post: 04-14-2003, 02:21 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96