I am a VB programmer and have purchased MP2004 to test integration of mapping in an application my company is developing. I have installed MP on my development machine which is running Windows XP SP2, VB6 SP5. XP SP2 is up to date with live update. When I insert the code from the MS example VB6 files and try to run it, I get the famous Run-time error 16398 others have talked about here.

The message is "Mappoint North America can't be run because it is not registered on your system, or it can't be found. This error occurs on the VB6 code: MappointControl1.NewMap geoMapNorthAmerica

I have uninstalled it and reinstalled it. I have made sure I have run the MP application at least once to activate the EULA. I have tried the "C:\Program Files\Microsoft MapPoint\MapPoint.exe" /regserver command as suggested by others. Nothing changes the message.

I take the same test code to a server running Windows Server 2003 and my code works perfectly - opens a map right up.

I tried getting help from Microsoft support and put in a help ticket - but of course they said "We can't help you with PROGRAMMING issues, however I contend that what I am doing is straight up out of the box with the OCX provided with the package. I suspect this error might be due to SP2 or a conflict with something else on my machine.

Any suggestions from the group. I have hit a dead end at Microsoft.