PDA

View Full Version : I have tried for some time to link to data stored ....



Anonymous
07-31-2001, 01:27 PM
I have tried for some time to link to data stored in a secure Access database. I get the message 'There was a problem opening this file x:\test.mdb. The file is not in the expected format.'

I am able to attach to unsecured datbases with no problems.

I am using MapPoint 2002, but also had the problem in MapPoint 2001.

Thank You

Anonymous
07-31-2001, 01:27 PM
You've hit on a known limitation of MapPoint. The product will not allow you to connect to password-protected datasources.

samoht
06-23-2006, 06:29 AM
I know this is 5 years old, but it is still a problem and this thread still shows up if you search for an answer.

Anyway, the answer (now?) is to create a UDL file which points to your database, containing the username and password, and then link or import data with this UDL file, rather than the MDB directly. I found that using 'OLE provider for ODBC Drivers', building a connection string, saving the database password in the UDL file, and then entering the database name as the 'initial catalogue to use' allowed Mappoint to get into my database.

WonderMonkey
06-24-2006, 10:00 AM
Good information. Thanks for updating.