PDA

View Full Version : Your registry settings for this application were not copied correctly....



Eric Frost
02-17-2011, 01:30 PM
A customer who was having problems getting the MapPoint 2010 install to work properly writes --


Eureka!

I got an email advertisement from WinZip yesterday about a security package they had called WinZip System Utilities Suite. It looked good and I thought it might clean up my “Administrator” problem that was forcing me right click on the MapPoint 2010 icon and, then, select “Run as Administrator” to avoid getting this popup:

After I installed and ran the WinZip program, MapPoint opened right up without my having to right click on the icon and without the popup. However, I still got the 429 “activex component can't create object" error at the point in the program when I had: CreateObject("MapPoint.Application.17.NA"). I had previously tried changing "MapPoint.Application.17.NA" to other variations with no luck, but decided to try it again. When I set it to "MapPoint.Application.17 ", up came the map….no error messages.

I had tried several security cleanups previously…..even from Microsoft with no luck. I hadn’t however totally redone my logon. Likely that would also have done the job.

Eric Frost
02-17-2011, 08:15 PM
Customer adds that Winzip System Utilities Suite costs --


$39.95

The interesting thing is that I have another package (PCtools Registry Mechanic) that is supposed to clean the registry. It runs automatically every day and it had just run immediately before the WinZip leaving no errors so I expected the WinZip not to produce any registry errors, but there were more than a hundred. However, I think it was their Security cleanup process that did the job….more than 600 errors. I took a look at some of them before I let the program clean them up and, while I’m totally unfamiliar with what they do, I’m quite sure from the verbiage that some of them had to do with cleaning user rights.

Eric Frost
02-18-2011, 12:00 PM
More info --


A bit more background on this. After I got MapPoint 2010 to replace MapPoint 2004 in an Access 2003 mdb, I deleted MapPoint 2004 and installed 2010. When I clicked on the new MapPoint icon, I got a popup beginning with ‘Your registry settings for this application were not copied correctly’. As a result, I could not open MapPoint. I then spent a good 3 days following suggestions I found on the web. Some of it indicated that there were problems with the permissions I’d assigned to my logon user account although when I looked at it, it showed Administrator and I’ve been using that logon for a long time with Windows 7 Home Premium 32 and have installed many applications with no problems.

I found out on the web that you could right click on the icon and select Run as Administrator and MapPoint 2010 would open okay. I also made certain that the Microsoft MapPoint 17.0 Object Library was checked in the references. However, when I tried to run the MS Access vb that used MapPoint to develop user maps I got the 429 “activex component can't create object" error at the point in the program when I had: CreateObject("MapPoint.Application.17.NA"). I also tried “MapPoint.Application.NA” and “MapPoint.Application.17” with the same result.

While I was still working on that problem, I got the email advertisement for the WinZip System Utilities Suite. When I downloaded the trial version I noticed that it had a process called Security to clean up security issues. I decided to go ahead and purchase it so that it hopefully would resolve the issue I was having with the Administrator permission of my logon. By the way, I had previously run a Microsoft Fix It program (Diagnose and fix Windows security problems automatically (http://support.microsoft.com/mats/windows_security_diagnostic/en-us)) that was supposed to diagnose and fix Windows security problems automatically…..didn’t fix this particular problem. However, I suspect that if I had set up a new user account and replaced my logon account with it and deleted the old logon account, it might also have resolved this problem. I could also have followed instructions in Fix a corrupted user profile (http://windows.microsoft.com/en-US/windows7/Fix-a-corrupted-user-profile) titled ‘Fix a corrupted user profile’ to see if that would work.