PDA

View Full Version : Versions of MapPoint with Versions of Windows



jlewis
09-08-2011, 01:49 PM
Hi All,

Does anyone know of a definitive list of which versions of MapPoint work on which versions of Windows?

We have multiple clients - each with multiple machines - who use MapPoint as part of our software. We specify that all the machines at each client must be on the same version of MapPoint.

However, our application has been out there for a few years now (since MapPoint 2006) and we have to allow for backwards compatibility for those clients that won't upgrade.

I know we have some clients running MapPoint 2006 with Windows 7 (32 bit) but am not sure about 2006 and Win 7 64 bit. I've just tried installing 2006 on my new Win 7 64 bit laptop and it hangs on the splash screen! Does anyone else have similar experience?

Many thanks in advance...

Loftis
09-26-2011, 08:40 PM
We also have MP 2004 and MP 2006 tracking apps that our company still uses everyday. They run fine in Win7 in 32 bit mode but not 64. You have to run them in 32 bit mode even for Win7 64 but that is no big deal.

What is a big deal is that the development environment even for MP 2011 isn't compatible with VS 2010 Win7.... I know I couldn't believe it either. I have tried suggestions from every thread out-there and nothing works. You can get your runtime to work with a-bunch of trickery using some obscure scripts in your compiler but you will never get the design tool to work in VS2010 and Win7. The MS develpement team must not plan to take this product any further so we have dumped this wonderful product in favor of one of their competitors which doesn't have as many nice features or map details. We would go to Gxxxxe Mxpx or bing but the apps must work without internet connections sometimes and with a small footprint.

Again, We have no problem with XP or Win7 for runtime. Good Luck...

:surrender:

Eric Frost
09-26-2011, 09:57 PM
What are the product(s)? You're welcome to mention here. I personally use lots of stuff besides MS to augment and expand upon stuff for solutions, not unusual.

Eric

marcick
09-27-2011, 01:19 AM
What is a big deal is that the development environment even for MP 2011 isn't compatible with VS 2010 Win7....

What do you mean exactely ?
I'm actually testing MP2011 Europe with Visual Basic 2010 Express on a Win7 64 bit machine and I don't see any trouble.

Winwaed
09-27-2011, 07:41 AM
I am selling products developed on VS2010 with MapPoint 2006-2011 on a Win7 x64 system.
It DOES work! There must be something else that is different about your system.

jlewis
09-27-2011, 07:57 AM
Hi All,

I should just post here that I found the solution to my original problem!

After much uninstalling and reinstalling - not to mention swearing (!) - I stumbled across a post (in this very forum!) which put me right. I'm now berating myself because I feel that I really should have known that the fingerprint reader on my laptop was bound to have compatibility issues with MapPoint. Wow do I feel stupid for not knowing this!!!!!

John

Eric Frost
09-27-2011, 08:41 AM
http://www.mapforums.com/hp-fingerprint-reader-incompatibility-17692.html

Yeah where do you kids learn computer science these days? That used to be one of the first things they taught (fingerprint reader incompatible with mappoint), lol.

Eric

Loftis
10-03-2011, 12:49 AM
Eric,
The Map programming controls we are switching to is 'ThinkGeo' Desktop. Our legacy MP apps were MP2004 and MP2006. Again, the issue wasn't the runtime but we couldn't get the MP control even 2011 to work in design. When you add the control from the tool-box and stretch it to the size you need it will shrink to a size (0,0). When attempting to run without adding special code you first get an exception about Cross-Thread illegal. You can get by that with some threading tricks. Then you get exceptions when attempting to load any maps. You can get by that using some obscure scripts related to DEP in your Project->Compile->build events->Edit Post build to set the DEP flag. If you don't mind then adding code to size your map, it seems to work fine in runtime.

Our dev staff consists of 10 developers and every single one experienced these issues on Win7 32 and 64. But just to be sure that it wasn't some interference issue, I disabled my FingerPrint reader and a few other devices I didn't need and re-ran the test. Same result. Maybe it is some odd way or order that the MP application and VS2010 must be installed in but I don't really have anymore time to waste. The MS mappoint creators should have checked this stuff anyway.

I attached a screen shot to show what I see after adding the control to a form and stretching it to the full size of the form (i.e. shrinks to 0,0).

Thanks for responding and if anyone has discovered the tricks needed to make MP especially MP2006 work in VS2010 please post as MP is really an excellent product and much less expense for small deployments.