PDA

View Full Version : Retrieving the COM class factory for component with CLSID {31851F82-AFE6-11D2-A3C9-00C04F72F340} failed due to the following error: 80080005.



Ganesha Prasad
11-22-2011, 08:10 AM
I have installed MapPoint 2011 for North America TRIAL version on my system (running on Win XP), 3 days back.

From Start -> My Programmes, it works fine without any error. I am refering to Interop.MapPoint Application Object in one of my sample ASP.NET web project. Then it is failing to instantiate at the following line throwing above error -

Dim objApp As New MapPoint.Application.

From another thread in this forum, I founfd that it is EULA problem & verified in my HKEY_USER\MapPoint\18.0\USA & found that there is a EULA value of Dword with value 1.

But still I am getting this error. I have gone to dcomcnfg & set full permission to everyone. But still I am getting this error. Can any one help me resolve on this ?

Thanks in advance

Eric Frost
11-22-2011, 08:44 AM
MapPoint is not designed to work as an ASP component, in fact the license prohibits internet use.

However, there may be some cases such as when you have a license for all users and it's on an Intranet, where it would be legal, and there may be technical work-arounds, there have been lots of discussions on this in this forum, although I have to admit I'm not one who has tried this or gotten it working.

I would recommend to search this forum more. Here's a long thread I turned up:

http://www.mapforums.com/mappoint-2006-object-initialization-fails-asp-net-2-0-a-6174.html

Have you tried everything on there? I would recommend to post follow up as a continuation of that thread.

Eric