PDA

View Full Version : MapPoint.exe starts and immediately close



P.O.
05-28-2013, 09:51 AM
hi,
i have MapPoint 2010 installed on Windows 2003 server.
there is a C# web service that use it to calculate distances. it worked fine for one year but now MapPoint.exe does not run anymore.

MapPoint.exe start and immediately close, both if it's started from the service whether it is launched manually or by the service.

the service logged many errors:

"The server RPC is unavailable" ,

"Retrieving the COM class factory for component with CLSID {xxx...} failed due to the following error: 80080005."

and in the Windows System Event Viewer:

"The Server {xxx...} did not register with DCOM within the required timeout"


I checked the DCOMCnfg user permissions but it still does not work.
Any help will be appreciated.

Thanks
P.O.

Eric Frost
05-28-2013, 10:26 AM
Sorry I'm not familiar with this issue, but it could be you are logged in as a different user or what else might have changed?

Here's a KB article on the topic --

You may receive an "Error code 80080005 -- server execution failed." error message when you start many COM+ applications (http://support.microsoft.com/kb/870655)

Have you tried re-installing MapPoint or running mappoint.exe /regserver from the command prompt?

Hope this helps!

P.O.
05-29-2013, 02:50 AM
thanks for your reply Eric,
I tried to re-installing, but I choose repair option, and nothing changed.
can you tell me more about running mappoint.exe from the command prompt with /regserver option? what it does?
in the meantime i look at the link you sent me.

I noticed that the form for the EULA confirmation comes out when i start manually MApPoint, but it immediately close, I'm able to see it only by taking a screenshot.

Eric Frost
05-31-2013, 10:53 AM
Does MapPoint stay open?

So the EULA confirmation comes up, but does not let you click to confirm and goes away by itself?

mappoint.exe /regserver is done at the command prompt. First switch to the MapPoint Program Files directory. This fixes problems many times, but honestly I think you current issue may be with that EULA splash screen?

Eric

Winwaed
06-03-2013, 10:47 AM
I agree that COM registration is a leading candidate as to the cause of the problem, but I've found the /regserver option doesn't usually work for me (even though it should). Un-installing and re-installing MapPoint is slow and tedious but always fixes COM registration issues (for me at least).

Eric Frost
06-03-2013, 07:50 PM
Also, when you uninstall / reinstall, sometimes it helps if you choose a different directory. e.g. instead of the default

C:\Program Files (x86)\Microsoft MapPoint 2013\

Install to a different directory such as

C:\Program Files (x86)\MS MapPoint 2013\

Eric

P.O.
06-05-2013, 04:08 AM
http://www.mapforums.com/mappoint-2006-object-initialization-fails-asp-net-2-0-a-6174.html
I found this thread where users solved problems similar to mine, but on older versions of MapPoint. I tried one of the solutions but nothing changed.
I try uninstall/reinstall and the problem is still there, but in the same directory of before.
MapPoint does not stay open.

Eric Frost
06-05-2013, 09:20 AM
Is it possible the EULA acceptance button needs to be clicked for that user, thus preventing MapPoint to load?

Log is as that user and launch MapPoint manually or interactively from the Start menu.

Eric