PDA

View Full Version : Developed for MapPoint 2013 using MapPoint 2011



mpgrs
11-10-2014, 06:27 AM
Hello everybody!

I developed a tour calculator and finally everything is fine. But know there is a question:
Is it possible to run the MapPoint 2013 code (its a VB.NET programm with OCX) with a MapPoint 2011 Edtion?
Can i add the api reference to 2011 and it will work? I didn't have a licens for 2011 and i couldn't found something.

Thanks for your help!

Winwaed
11-10-2014, 07:51 AM
Windows COM might have a problem matching the API libraries (asking for '2013 or better' but 2011 precedes that), although the actual APIs are virtually identical.
Answer: Develop against MapPoint 2011, and that will work with MapPoint 2013.

mpgrs
11-11-2014, 05:01 AM
Hey thanks a lot! So i had to develop two vb.NET programms. One for 2013 and the other one for 2011, right?

Winwaed
11-11-2014, 08:08 AM
Just develop against 2011, and it will work against 2013.