PDA

View Full Version : Printing to two printers



BobFromBoston
01-04-2006, 05:58 PM
Greetings,

I would like to print reports to two different printers, but don't seem to find where in the MapPoint.PrintOut() function how to set the printer. I've been using the default printer, when printing to a single printer, but am hamstrung from using two printers if I can't find how to change the default printer.

Has anybody run into this problem before?

Thanks,
Bob

Dazzer
01-05-2006, 03:48 AM
I found this

http://www.mp2kmag.com/mappoint/discussion/viewtopic.asp?t=3345

I little more complex than I would hope, I've never had to use the Printout() method before but I had a look at it after reading your post and to be honest I'm suprised there is no option to set the printer you want to print too. Seems like something of an oversight really.

BobFromBoston
01-06-2006, 01:18 PM
Thanks. I ended up switching the default printer, programmatically, and it seems to be working. Yes, this is somewhat of an oversight, I suppose. But considering all that MapPoint ActiveX delivers, and for only $99 per license, I'll give them a pass on this one....

Bob

Dazzer
01-06-2006, 07:04 PM
$99 a license?! Where was that from, are we just paying a lot more in the uk? :evil:

BobFromBoston
01-06-2006, 07:10 PM
I had looked at the cost to resell MapPoint some time ago and found it to be around $99, when purchased and re-licensed. I have not yet finished my aplication, and hopefully will not find that the prices has increased substantially.

Eric Frost
01-07-2006, 07:43 AM
It is through the ISV-R program.. you have to go through a lot of hoops to get in including becoming a certified partner.
Eric

Olyvia Elfrieda
09-24-2009, 07:03 AM
Hi, I have two printers. Ink Jets that all of a sudden quit printing in black.
Suspecting the operating system I booted to the second hard drive which has Windows 2000 and both worked fine.I went back to the Windows XP drive and reloaded the driver for the Cannon Ink jet and still no black. Color is fine.
Anyone know of a virus or something causing this?