Welcome to MapForums!

Register, sign in, or use Facebook Connect above to join in and participate in the forum.

When you are signed in, this message, the ads in this row, and the red-underlined link ads all go away.

Subscribe to receive our newsletter.
Subscribe Unsubscribe
Results 1 to 4 of 4

System.ArgumentException: MapPoint failed to load. The cause of this failure is unknown.

This is a discussion on System.ArgumentException: MapPoint failed to load. The cause of this failure is unknown. within the MapPoint Desktop Discussion forums, part of the Map Forums category; Hi all, I get the following error. I have a vista and VS 2008 This was working good in the ...

  1. #1
    rowter is offline Member Green Belt
    Join Date
    Aug 2009
    Posts
    62

    System.ArgumentException: MapPoint failed to load. The cause of this failure is unknown.

    Hi all,

    I get the following error.
    I have a vista and VS 2008
    This was working good in the debug mode of the VS.
    After creating the setup and tried to execute the file, i get this error whenever i try to access the mappoint file.
    I was searching the forums for this kind of errors and i see several people having the same issue without any resolution.
    Any help would be greatly appreciated.

    See the end of this message for details on invoking
    just-in-time (JIT) debugging instead of this dialog box.
    ************** Exception Text **************
    System.ArgumentException: MapPoint failed to load. The cause of this failure is unknown.
    at MapPoint.IMappointCtrl.NewMap(Object Template)
    at AxMapPoint.AxMappointControl.NewMap(Object template)
    at trTransportationMgrProject.frm_Client.frm_Client_L oad(Object sender, EventArgs e)
    at System.Windows.Forms.Form.OnLoad(EventArgs e)
    at System.Windows.Forms.Form.OnCreateControl()
    at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
    at System.Windows.Forms.Control.CreateControl()
    at System.Windows.Forms.Control.WmShowWindow(Message& m)
    at System.Windows.Forms.Control.WndProc(Message& m)
    at System.Windows.Forms.ScrollableControl.WndProc(Mes sage& m)
    at System.Windows.Forms.ContainerControl.WndProc(Mess age& m)
    at System.Windows.Forms.Form.WmShowWindow(Message& m)
    at System.Windows.Forms.Form.WndProc(Message& m)
    at System.Windows.Forms.Control.ControlNativeWindow.O nMessage(Message& m)
    at System.Windows.Forms.Control.ControlNativeWindow.W ndProc(Message& m)
    at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

    ************** Loaded Assemblies **************
    mscorlib
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.3074 (QFE.050727-3000)
    CodeBase: file:///C:/Windows/Microsoft.NET/Fra...7/mscorlib.dll
    ----------------------------------------
    trTransportationMgrProject
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///C:/Program%20Files/Default%2...MgrProject.exe
    ----------------------------------------
    System.Windows.Forms
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.3053 (netfxsp.050727-3000)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL...dows.Forms.dll
    ----------------------------------------
    System
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.3053 (netfxsp.050727-3000)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL...089/System.dll
    ----------------------------------------
    System.Drawing
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.3053 (netfxsp.050727-3000)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL...em.Drawing.dll
    ----------------------------------------
    trBaseControls
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///C:/Program%20Files/Default%2...seControls.DLL
    ----------------------------------------
    Microsoft.VisualBasic
    Assembly Version: 8.0.0.0
    Win32 Version: 8.0.50727.3053 (netfxsp.050727-3000)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL...isualBasic.dll
    ----------------------------------------
    PresentationCore
    Assembly Version: 3.0.0.0
    Win32 Version: 3.0.6920.1500 built by: QFE
    CodeBase: file:///C:/Windows/assembly/GAC_32/P...tationCore.dll
    ----------------------------------------
    WindowsBase
    Assembly Version: 3.0.0.0
    Win32 Version: 3.0.6920.1453 built by: NetFX
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL...indowsBase.dll
    ----------------------------------------
    trUtilities
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///C:/Program%20Files/Default%2...rUtilities.DLL
    ----------------------------------------
    System.Data
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.3053 (netfxsp.050727-3000)
    CodeBase: file:///C:/Windows/assembly/GAC_32/S...ystem.Data.dll
    ----------------------------------------
    System.Configuration
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.3053 (netfxsp.050727-3000)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL...figuration.dll
    ----------------------------------------
    System.Xml
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.3074 (QFE.050727-3000)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL...System.Xml.dll
    ----------------------------------------
    System.Transactions
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.3053 (netfxsp.050727-3000)
    CodeBase: file:///C:/Windows/assembly/GAC_32/S...ansactions.dll
    ----------------------------------------
    System.EnterpriseServices
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.3053 (netfxsp.050727-3000)
    CodeBase: file:///C:/Windows/assembly/GAC_32/S...seServices.dll
    ----------------------------------------
    AxInterop.MapPoint
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///C:/Program%20Files/Default%2...p.MapPoint.DLL
    ----------------------------------------
    Interop.MapPoint
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///C:/Program%20Files/Default%2...p.MapPoint.DLL
    ----------------------------------------
    ************** JIT Debugging **************
    To enable just-in-time (JIT) debugging, the .config file for this
    application or computer (machine.config) must have the
    jitDebugging value set in the system.windows.forms section.
    The application must also be compiled with debugging
    enabled.
    For example:
    <configuration>
    <system.windows.forms jitDebugging="true" />
    </configuration>
    When JIT debugging is enabled, any unhandled exception
    will be sent to the JIT debugger registered on the computer
    rather than be handled by this dialog box.

  2. #2
    rowter is offline Member Green Belt
    Join Date
    Aug 2009
    Posts
    62

    Re: System.ArgumentException: MapPoint failed to load. The cause of this failure is unknown.

    This issue occurred when the testmachines were having mappoint 2006.
    Upgrade to Mappoint 2009 solved the problem.

  3. #3
    Wilfried is offline Senior Member Black Belt
    Join Date
    Nov 2004
    Location
    Belgium
    Posts
    2,433

    Re: System.ArgumentException: MapPoint failed to load. The cause of this failure is unknown.

    Hi,

    Good that it is solved. However I find it strange that it was not with mp2006...

  4. #4
    rowter is offline Member Green Belt
    Join Date
    Aug 2009
    Posts
    62

    Re: System.ArgumentException: MapPoint failed to load. The cause of this failure is unknown.

    strange thing is the same configuration was working good in win xp but failing in vista.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Mappoint failed to load - Mappoint Active X Problem
    By rmpandu in forum MapPoint Desktop Discussion
    Replies: 3
    Last Post: 12-09-2008, 01:11 PM
  2. Mappoint failed to load error..
    By kbtech in forum Development
    Replies: 1
    Last Post: 07-03-2008, 03:12 AM
  3. MapPoint Addin failed to load
    By satrapu in forum MapPoint Desktop Discussion
    Replies: 0
    Last Post: 11-03-2005, 03:40 AM
  4. MapPoint failed to load...
    By eltrigo in forum MapPoint Desktop Discussion
    Replies: 1
    Last Post: 08-16-2005, 03:27 PM
  5. Mappoint Failed to load error
    By starbuck in forum MapPoint Desktop Discussion
    Replies: 5
    Last Post: 11-08-2004, 06:37 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127