Welcome to MapForums!

Register, sign in, or use Facebook Connect above to join in and participate in the forum.

When you are signed in, this message, the ads in this row, and the red-underlined link ads all go away.

Subscribe to receive our newsletter.
Subscribe Unsubscribe
Results 1 to 2 of 2

'Unable to get directions' error

This is a discussion on 'Unable to get directions' error within the MapPoint Desktop Discussion forums, part of the Map Forums category; I thought I would post this for information for everyone. My sites occasionally get a MapPoint error which I cannot ...

  1. #1
    Anonymous is offline Senior Member Black Belt
    Join Date
    Jul 2002
    Posts
    5,137

    'Unable to get directions' error

    I thought I would post this for information for everyone. My sites occasionally get a MapPoint error which I cannot trap in VB, when calculating the route between deliveries. The runtime error is:

    "Unable to get directions from Start to 450. One of the areas may not contain necessary connectors such as ferry routes or main roads. Move one or both of the stops, and try again."

    This is annoying as the calculate freezes for anything up to twenty minutes before actually crashing!

    Last time it happened I spent time looking at the delivery points, all of which seemed fine and were mapped in exactly the right places. I discovered the problem disappeared if I moved just one of them fifty yards up the road, even though there were no junctions between the old and new positions.

    It appears the problem is due to data corruption or missing data or something similar within the Microsoft data, as after moving the point the route was calculated perfectly happily!

    Just thought I would let you all know...
    Stuart

  2. #2
    philjones10 is offline Junior Member White Belt
    Join Date
    Mar 2010
    Posts
    1

    Re: 'Unable to get directions' error

    Nice one Stuart. That worked.

    I am using Excel VBA to control MapPoint, passing it OS Grid References (about 165000 of them). I have 12 digit numerical references (6 for x, 6 for y) for each point.

    I have got some error handling on the function which looks up the travel times/distances and, when this error pops up, I am just incrementing the 12 digit reference by one and trying it again, effectively moving the point ten centimetres, or one centimetre (i'm not sure which) north. So far it's only needed to do it once so the point doesn't move much. And the error only pops up intermitently anyway (about one in 10000 or so).

    Great!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Unable to get directions from locA to locB
    By BobFromBoston in forum MapPoint Desktop Discussion
    Replies: 3
    Last Post: 06-21-2006, 04:08 PM
  2. Unable to get directions from locA to locB.
    By BobFromBoston in forum MapPoint Desktop Discussion
    Replies: 3
    Last Post: 04-01-2006, 10:03 AM
  3. Please helpe me! Unable to start Mappoint without Run-CD
    By herrbie2000 in forum MapPoint Desktop Discussion
    Replies: 1
    Last Post: 08-22-2005, 04:41 PM
  4. ESRI imports unable to zoom in
    By Anonymous in forum MapPoint Desktop Discussion
    Replies: 1
    Last Post: 02-02-2005, 04:02 PM
  5. I am posting this again, because I am still unable....
    By Anonymous in forum MapPoint Desktop Discussion
    Replies: 3
    Last Post: 06-12-2002, 11:30 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25