Welcome to MapForums!

Register, sign in, or use Facebook Connect above to join in and participate in the forum.

When you are signed in, this message, the ads in this row, and the red-underlined link ads all go away.

Subscribe to receive our newsletter.
Subscribe Unsubscribe
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Vista APPCRASH problem

This is a discussion on Vista APPCRASH problem within the MapPoint Desktop Discussion forums, part of the Map Forums category; I have a .net application that uses the MapPoint 2006 object model, and it has been rock-solid for a year ...

  1. #1
    oxcarz is offline Junior Member Yellow Belt
    Join Date
    Sep 2005
    Posts
    22

    Vista APPCRASH problem

    I have a .net application that uses the MapPoint 2006 object model, and it has been rock-solid for a year on XP. After an upgrade to Vista Business, the app started crashing occasionally with the MapPoint internal error pop-up: "MapPoint has stopped working and must close".
    Name= APPCRASH
    Module 13.0.15.2800
    Exceptipon Code c0000005
    offset 0018601e
    LCID 1033

    The .net part is not able to handle these errors. Everything is try-catched, and I also have a global handler that is also not handling the error:

    AddHandler System.Windows.Forms.Application.ThreadException, AddressOf myEhandler

    So the error is thrown inside the mapPoint control. It happens occasionally and randomly so it is impossible to reproduce and even harder to debug. I have turned off ALL firewalls, Defender, UAC is off, etc.

    Other than going back to XP, I have run out of ideas. Although it is possible I am the only one in the world that will ever have this problem, I have a feeling that as Vista becomes widely adopted, this thread may get some activity.

    Ox
    Last edited by oxcarz; 08-03-2007 at 06:42 AM.

  2. #2
    Wilfried is offline Senior Member Black Belt
    Join Date
    Nov 2004
    Location
    Belgium
    Posts
    2,433

    Re: Vista APPCRASH problem

    Hi,

    I have no idea, but the only thing that come into mind is: Try to install and run your application as Administrator with full rights. If you don't have the error any more it has something to do with security.

  3. #3
    oxcarz is offline Junior Member Yellow Belt
    Join Date
    Sep 2005
    Posts
    22

    Re: Vista APPCRASH problem

    Thanks Wilfired.
    I have User Access COntrol (UAC) turned off, so everything should be running as admin. But you gave me idea I will try:

    I made a config xml for the application to force it to use .net 2.0:

    <configuration>
    <startup>
    <supportedRuntime version="v2.0.50727"/>
    </startup>
    </configuration>

    I also tried setting "compatibility mode" by right-clicking the app's .exe, but I get a "windows did not save the registry settings correctly" error. I get this error for both my .net app and mapPoint.exe.

    I doubt any of this will make a difference because the problem is an un-handled exeception in the .ocx, so these .net settings wont really help.

    I did start a support case with Microsoft because I did find a post somewhere that mentioned Microsoft was aware of the MapPoint c0000005 issues. But this was a few days ago and I havent heard from them, so I wont hold my breath. However, in the unlikely event I hear from them, I will share their wisdom here.

  4. #4
    Wilfried is offline Senior Member Black Belt
    Join Date
    Nov 2004
    Location
    Belgium
    Posts
    2,433

    Re: Vista APPCRASH problem

    Hi,

    Yes please share the wisdom because this will benefit lots of people in the future.

    BTW: Microsoft has also a Vista newsgroup with a lot of MVP's listening on it. I should advice to post same question over there too, eventually with a small test program to show the error.

  5. #5
    oxcarz is offline Junior Member Yellow Belt
    Join Date
    Sep 2005
    Posts
    22

    Re: Vista APPCRASH problem

    Unfortunately, we cant expect any help from Microsoft. They simply redirected my support ticket to MapPoint web services. The Web Service group told me to get support from the Home Products Group:

    Thank you for contacting Microsoft's Home Product Support. My name is Rahul Aher. I see that you are having a MappOint Object Model issue. The Microsoft Home Products Support team manages Service Requests directly related to the product itself. For MappOint Object Model issue, you will need to contact the appropriate group listed below for your issue type. Just click on the link below.....

    I am in the endless loop from hell! This was actualy the first (and last) time I ever went to Microsoft for help. Thankfully we have this forum.

  6. #6
    Wilfried is offline Senior Member Black Belt
    Join Date
    Nov 2004
    Location
    Belgium
    Posts
    2,433

    Re: Vista APPCRASH problem

    Hi,

    I have no idea of solution at the moment. Maybe someone else have.

  7. #7
    oxcarz is offline Junior Member Yellow Belt
    Join Date
    Sep 2005
    Posts
    22

    Re: Vista APPCRASH problem

    I am trying the "compatibility mode". I tried to set this before but I was doing it wrong. You cant right-click the mapPoint.exe and change the Compatibility properties of an existing installation. I needed to un-install, insert the CD, use file explorer to find the setup.exe on the CD, then right-click setup.exe>properties>Compatibility mode> Win XP SP2. Then I ran the setup.exe

    This installed mapPoint and set Compatibility MOde to Win XP SP2

    So now for some testing. This may take awhile because it sometimes runs for a few days without an error. I am not very hopeful though. The compatibility mode forces MapPoint to use legacy Windows system files, but I doubt it affects how the .ocx activeX control runs..I may be wrong.

    Ox

  8. #8
    oxcarz is offline Junior Member Yellow Belt
    Join Date
    Sep 2005
    Posts
    22

    Re: Vista APPCRASH problem

    doh! I posted too quickly. When I run the MP.exe I get the same old "Registry settings were not copied correctly" error. There may be a way to force XP mode by inserting a compatMode key in the registry, but I dont have a clue where it would go...this would take some trial and error.

  9. #9
    oxcarz is offline Junior Member Yellow Belt
    Join Date
    Sep 2005
    Posts
    22

    Re: Vista APPCRASH problem

    Another update: I actually created a MS support incident (my fisrt ever...and last). They were not able to solve the problem of running MP in XP compatibility mode. The final work-around was to run the application as administrator and make sure the permissions are all set to "full". Not much help to me since thjis was the first thing I tried.

    We un-installed Vista and went back to WIndows Server 2003 since the application has NEVER crashed in XP pro or WS2003. I may re-visit Vita after a service pack or 2.

    Oc

  10. #10
    oxcarz is offline Junior Member Yellow Belt
    Join Date
    Sep 2005
    Posts
    22

    Re: Vista APPCRASH problem

    Another update:
    About 3 weeks ago (Aug 29, 2007) I added these Windows Updates:
    KB939159,938979,933360, and 938194.

    I hate to jynx myself, but 1 of these may have fixed the problem since I have not had the APPCRASH since then.

    Please dont run out and buy Vista on my say-so. Personally, for a mission-critical application, I would wait for a service pack or 2. This Vista server is just a test-server for us. We run Windows Server 2003 for anything important.

    Ox

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. VB6 Com Add-In Not Working on Vista
    By dmaestro22 in forum MapPoint Desktop Discussion
    Replies: 6
    Last Post: 02-11-2012, 04:40 PM
  2. Vista Gadget That Tracks the International Space Station
    By Eric Frost in forum MP2K Magazine Articles
    Replies: 2
    Last Post: 01-21-2009, 11:20 AM
  3. Using Virtual Earth in a Vista Gadget
    By Eric Frost in forum MP2K Magazine Articles
    Replies: 1
    Last Post: 01-21-2009, 11:18 AM
  4. Upgrade to Vista - Check Readiness
    By Eric Frost in forum News and Announcements
    Replies: 3
    Last Post: 10-15-2007, 01:53 PM
  5. VISTA and mappoint 2007 data importing
    By mastaBH in forum MapPoint Desktop Discussion
    Replies: 8
    Last Post: 08-17-2007, 11:11 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59